Vumatel - Queensburgh
Incident Report for GreyTech
Investigating
Customers are reporting issues with connecting in Queensburgh, KZN.
Issue us been reported to Vumatel.
Posted Oct 01, 2021 - 21:36 UTC
This incident affects: Fibre Network.