Vumatel fibre break - Three Rivers, Vereeniging
Incident Report for GreyTech
Identified
Engineers are on site and working to restore the affected area.
Posted May 16, 2021 - 10:53 UTC
Investigating
Vumatel is currently experiencing a fibre break in Three Rivers, Vereeniging. Engineers are currently working on restoring services in the area.

Reference: 5139

Area/s affected:

Three Rivers, Vereeniging
Posted May 16, 2021 - 10:49 UTC
This incident affects: Fibre Network.