Frogfoot Outage: George

Incident Report for GreyTech

Identified

Engineers are on site and working to restore the affected area.
Posted May 16, 2021 - 10:54 UTC

Investigating

Frogfoot is currently experiencing an outage in George. Engineers are currently working on restoring services in the affected area.

Reference: FRG1315531
Posted May 16, 2021 - 10:49 UTC
This incident affects: Fibre Network.