Telkom LTE Usage Updates
Incident Report for GreyTech
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2021 - 10:54 UTC
Investigating
We are currently experiencing delays with retrieving usage updates from Telkom for our Telkom LTE services. Our engineers are working to speed up the process in getting the updated usages. We apologise for the inconvenience caused.
Posted Mar 31, 2021 - 07:12 UTC
This incident affects: Mobile Network.